DEBIAN 10.1 (BUSTER) UPDATE NOTES

DEBIAN 10.1 (BUSTER) UPDATE NOTES

The latest point release of Debian 10 was released on 07/09/2019. I updated in the usual way. However lsb_release -a didn’t tell me that I was running 10.1:

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 10 (buster)
Release: 10
Codename: buster

I asked about this on the Debian users list and it appears that lsb_release is no longer used, as “Debian is not LSB-conformant”.

On advice, I have now removed lsb_release with

apt remove lsb-release (see Important note below)

I was advised to use:

cat /etc/debian_version instead

If this seems, that it will be rather tedious each time then using:

alias debver=’cat /etc/debian_version’

will help by aliasing the a debver command.

Adding this to .bashrc will make the changes permanent ( or until you change this manually )

I have also added :

echo “You are running :”
debver

To the end of .bashrc so debver runs each time I start a terminal window.

Hope this helps.

 

IMPORTANT UPDATE PLEASE READ

Removing lsb_release, also removed other packages, however doing so has some how broken the lxde desktop.  Not too sure what has gone wrong.  To get round this, and having tried a few other things, I installed the XFCE desktop.   So at least got my system back to a more usable condition.  I think lxde desktop is best left installed.